summaryrefslogtreecommitdiff
path: root/dev-util/bazel/bazel-1.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/bazel/bazel-1.0.1.ebuild')
-rw-r--r--dev-util/bazel/bazel-1.0.1.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-util/bazel/bazel-1.0.1.ebuild b/dev-util/bazel/bazel-1.0.1.ebuild
index 84224be11667..25dd653392af 100644
--- a/dev-util/bazel/bazel-1.0.1.ebuild
+++ b/dev-util/bazel/bazel-1.0.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -43,8 +43,9 @@ bazel-get-flags() {
}
pkg_setup() {
- echo ${PATH} | grep -q ccache && \
+ if has ccache ${FEATURES}; then
ewarn "${PN} usually fails to compile with ccache, you have been warned"
+ fi
java-pkg-2_pkg_setup
}
@@ -63,6 +64,9 @@ src_prepare() {
# R: /proc/24939/setgroups
# C: /usr/lib/systemd/systemd
addpredict /proc
+
+ eapply "${FILESDIR}/${PN}-0.24.1-rename-gettid-functions.patch"
+ eapply "${FILESDIR}/${PN}-0.22.0-include-limits-for-gcc-11.patch"
}
src_compile() {