summaryrefslogtreecommitdiff
path: root/dev-util/azuredatastudio
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/azuredatastudio')
-rw-r--r--dev-util/azuredatastudio/Manifest2
-rw-r--r--dev-util/azuredatastudio/azuredatastudio-1.48.0.ebuild105
2 files changed, 107 insertions, 0 deletions
diff --git a/dev-util/azuredatastudio/Manifest b/dev-util/azuredatastudio/Manifest
index dafd5bb0f8f6..b0a2fff66487 100644
--- a/dev-util/azuredatastudio/Manifest
+++ b/dev-util/azuredatastudio/Manifest
@@ -1,3 +1,5 @@
DIST azuredatastudio-1.47.1-amd64.deb 138850108 BLAKE2B f99374c00595f18f4a62e676235e1c5f71a47f14351ef3dc60c0bc84a69d15c325309be77613a4ba564e0f1322aed4fccc840ca871b83d0bbe2d48150e735afb SHA512 ad310cbb9955b8e46f8fdbcceb45ada6e61e2de8c0c40ff93312e7510f43fe675f1239ac07e095fee5573f034efc6fefbde13ebf70bae2f75e297a0e0e95df32
+DIST azuredatastudio-1.48.0-amd64.deb 135137768 BLAKE2B 92798acdfb2871f0ecc12ba33c2608357230ae7f6153012711d111586beae827771de804db17f66cb2d9429741b0dae7776727296625683037ad539777c8c977 SHA512 5781f26a1f53a16561adac910675ef8d944211838b127c271e65ce0e5d88eb91c0290d5b731f418742327d275f69ea26cde412dfc6833b2039dab6813f1943af
EBUILD azuredatastudio-1.47.1-r1.ebuild 2398 BLAKE2B e4044061e59375a5014aa0f8d9128fd7adc694c7b115a1f0bcde46a6d963477f5b1336356e0d953b7216d0640b67dce33742ea59492dd6be987584c654ad232b SHA512 9e8825f451259637c710e29fa69739235c3e89874e3501b163f3692b7913edc015c7f737488cf9347d29062931c7bb6eaf8b0fd2383cad008ed13d90b53de587
+EBUILD azuredatastudio-1.48.0.ebuild 2398 BLAKE2B db21b0bde24d816e8147e6fd79c663fd75d555b3014df30c8f8f5eae6f5619f3616e8cc16e6c71963b5896b9a94538a02707b7ebe5e3f939854827e082834d06 SHA512 ef2d5c3ddb765eb23d6ab5671c38d5d323d9d56d251b426900973b0caba84b3c581cd30839ff175ec7fc7a3b4f92aa32f6e0f850014c9b717385703d88aea6e7
MISC metadata.xml 822 BLAKE2B 72cadf27f137f7276f8cd3b3fc81afd0ac1eefa9f12e39aea8d81705454a17aa8d2b49de9d61c0523fda304dcf0363ef463d0b2fdbd04a524aa63a2ced6a6a6a SHA512 27dbc8a269df130994b8d59cefb193440b276638ef460f68d72e887dc02d40473218febc1ecf242a51f55593d90a3ea42255e4a8d8ce4237421c9e56e52c7030
diff --git a/dev-util/azuredatastudio/azuredatastudio-1.48.0.ebuild b/dev-util/azuredatastudio/azuredatastudio-1.48.0.ebuild
new file mode 100644
index 000000000000..d8d032ceea34
--- /dev/null
+++ b/dev-util/azuredatastudio/azuredatastudio-1.48.0.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit unpacker xdg
+
+DESCRIPTION="Data management and development tool from Microsoft"
+HOMEPAGE="https://learn.microsoft.com/sql/azure-data-studio/
+ https://github.com/microsoft/azuredatastudio/"
+SRC_URI="
+ amd64? (
+ https://azuredatastudio-update.azurewebsites.net/${PV}/linux-deb-x64/stable
+ -> ${P}-amd64.deb
+ )
+"
+S="${WORKDIR}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+IUSE="kerberos"
+RESTRICT="bindist"
+
+# This is based on VSCode/VSCodium, so just copy their "RDEPEND".
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ app-crypt/libsecret[crypt]
+ app-misc/ca-certificates
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ dev-util/lttng-ust:0/2.12
+ media-libs/alsa-lib
+ media-libs/libcanberra[gtk3]
+ media-libs/libglvnd
+ media-libs/mesa
+ net-misc/curl
+ net-print/cups
+ sys-apps/dbus
+ sys-libs/zlib
+ sys-process/lsof
+ x11-libs/cairo
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libnotify
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libxkbcommon
+ x11-libs/libxkbfile
+ x11-libs/libXrandr
+ x11-libs/libXScrnSaver
+ x11-libs/pango
+ x11-misc/xdg-utils
+ kerberos? ( app-crypt/mit-krb5 )
+"
+DEPEND="
+ dev-libs/openssl-compat:1.0.0
+"
+BDEPEND="
+ dev-util/patchelf
+"
+
+QA_PREBUILT="*"
+
+src_unpack() {
+ unpack_deb "${A}"
+}
+
+src_prepare() {
+ default
+
+ cd "${S}/usr/share" || die
+
+ mv appdata metainfo || die
+ mv zsh/vendor-completions zsh/site-functions || die
+
+ cd "${PN}" || die
+
+ # Kerberos libs, same issue as VSCode/VSCodium.
+ if ! use kerberos ; then
+ rm -r resources/app/node_modules.asar.unpacked/kerberos || die
+ fi
+
+ # Patch "System.Security.Cryptography.Native.OpenSsl.so": *.so.10 -> *.so.1.0.0
+ local mssql_ext_version=4.11.1.1
+ local mssql_ext_lib=System.Security.Cryptography.Native.OpenSsl.so
+ cd "resources/app/extensions/mssql/sqltoolsservice/Linux/${mssql_ext_version}" || die
+ patchelf --add-needed libcrypto.so.1.0.0 "${mssql_ext_lib}" || die
+ patchelf --add-needed libssl.so.1.0.0 "${mssql_ext_lib}" || die
+ patchelf --remove-needed libcrypto.so.10 "${mssql_ext_lib}" || die
+ patchelf --remove-needed libssl.so.10 "${mssql_ext_lib}" || die
+ rm System.Native.a || die
+}
+
+src_install() {
+ cp -r . "${ED}" || die
+
+ dosym -r "/usr/share/${PN}/${PN}" "/usr/bin/${PN}"
+}