summaryrefslogtreecommitdiff
path: root/dev-util/apitrace/files
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/apitrace/files')
-rw-r--r--dev-util/apitrace/files/apitrace-9.0-pkgconfig-waffle.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/dev-util/apitrace/files/apitrace-9.0-pkgconfig-waffle.patch b/dev-util/apitrace/files/apitrace-9.0-pkgconfig-waffle.patch
new file mode 100644
index 000000000000..6d0450886672
--- /dev/null
+++ b/dev-util/apitrace/files/apitrace-9.0-pkgconfig-waffle.patch
@@ -0,0 +1,14 @@
+waffle's upstream intentionally does not ship cmake files anymore
+(just a quick fix that works for us, there may be more to consider)
+
+https://bugs.gentoo.org/901365
+https://gitlab.freedesktop.org/mesa/waffle/-/issues/74
+https://gitlab.freedesktop.org/mesa/waffle/-/commit/a16983fea590491727c8119256c7b938fe1f9d10
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -195,3 +195,4 @@
+ # Use Waffle for eglretrace
+- find_package (Waffle REQUIRED)
++ find_package(PkgConfig REQUIRED)
++ pkg_check_modules(Waffle REQUIRED waffle-1)
+ endif ()