summaryrefslogtreecommitdiff
path: root/dev-util/abootimg/abootimg-20150323-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/abootimg/abootimg-20150323-r1.ebuild')
-rw-r--r--dev-util/abootimg/abootimg-20150323-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-util/abootimg/abootimg-20150323-r1.ebuild b/dev-util/abootimg/abootimg-20150323-r1.ebuild
new file mode 100644
index 000000000000..e2e7a47c1899
--- /dev/null
+++ b/dev-util/abootimg/abootimg-20150323-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+COMMIT="1ebeb393252ab5aeed62e34bc439b6728444f06e"
+DESCRIPTION="Manipulate Android boot images"
+HOMEPAGE="https://gitlab.com/ajs124/abootimg"
+SRC_URI="https://gitlab.com/ajs124/abootimg/-/archive/${COMMIT}/abootimg-${COMMIT}.tar.bz2 -> ${P}.tar.bz2"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND="sys-apps/util-linux"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin abootimg
+}