summaryrefslogtreecommitdiff
path: root/dev-tex/svninfo/svninfo-0.7.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tex/svninfo/svninfo-0.7.4.ebuild')
-rw-r--r--dev-tex/svninfo/svninfo-0.7.4.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-tex/svninfo/svninfo-0.7.4.ebuild b/dev-tex/svninfo/svninfo-0.7.4.ebuild
new file mode 100644
index 000000000000..01f0670f028c
--- /dev/null
+++ b/dev-tex/svninfo/svninfo-0.7.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=0
+
+inherit latex-package eutils
+
+LICENSE="LPPL-1.2"
+DESCRIPTION="A LaTeX module to access SVN version info"
+HOMEPAGE="http://www.brucker.ch/projects/svninfo/index.en.html"
+SRC_URI="http://www.brucker.ch/projects/svninfo/download/${P}.tar.gz"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+DOCS="README"
+
+TEXMF=/usr/share/texmf-site
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-0.5-latex-compile.patch"
+}
+
+src_compile() {
+ export VARTEXFONTS="${T}/fonts"
+ emake -j1 || die "compilation failed"
+}