summaryrefslogtreecommitdiff
path: root/dev-tex/style-check/style-check-0.14.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tex/style-check/style-check-0.14.ebuild')
-rw-r--r--dev-tex/style-check/style-check-0.14.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/dev-tex/style-check/style-check-0.14.ebuild b/dev-tex/style-check/style-check-0.14.ebuild
index 57b9aa826bd5..c5b480c27b0d 100644
--- a/dev-tex/style-check/style-check-0.14.ebuild
+++ b/dev-tex/style-check/style-check-0.14.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
DESCRIPTION="Parses LaTeX-formatted text in search of forbidden phrases"
HOMEPAGE="http://www.cs.umd.edu/~nspring/software/style-check-readme.html https://github.com/nspring/style-check"
@@ -12,11 +12,13 @@ SLOT="0"
KEYWORDS="amd64 ~ppc x86"
IUSE="test"
-RDEPEND="dev-lang/ruby"
-DEPEND="test? ( dev-lang/ruby )"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-lang/ruby:*"
+DEPEND="test? ( dev-lang/ruby:* )"
src_install() {
dodir /etc/style-check.d
emake PREFIX="${EPREFIX}/usr" DESTDIR="${ED}" install
- dohtml README.html
+ dodoc README.html
}