summaryrefslogtreecommitdiff
path: root/dev-tex/rubber/rubber-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tex/rubber/rubber-9999.ebuild')
-rw-r--r--dev-tex/rubber/rubber-9999.ebuild23
1 files changed, 13 insertions, 10 deletions
diff --git a/dev-tex/rubber/rubber-9999.ebuild b/dev-tex/rubber/rubber-9999.ebuild
index 52c54772aed8..bac70181e992 100644
--- a/dev-tex/rubber/rubber-9999.ebuild
+++ b/dev-tex/rubber/rubber-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
PYTHON_COMPAT=( python3_{9..11} )
-DISTUTILS_USE_SETUPTOOLS="no"
+DISTUTILS_USE_PEP517=hatchling
inherit distutils-r1
@@ -12,10 +12,9 @@ if [[ ${PV} == "9999" ]] || [[ -n "${EGIT_COMMIT_ID}" ]]; then
inherit git-r3
EGIT_REPO_URI="https://gitlab.com/latex-rubber/${PN}.git"
else
- UPSTREAM_PV=$(ver_rs 3 -)
- SRC_URI="https://gitlab.com/latex-rubber/${PN}/-/archive/${UPSTREAM_PV}/${PN}-${UPSTREAM_PV}.tar.bz2"
- S="${WORKDIR}/${PN}-${UPSTREAM_PV}"
- KEYWORDS="~amd64 ~ppc ~x86"
+ # NOTE: Cannot be "PYPI_PN=latex-rubber" + "inherit pypi" due to missing tests
+ SRC_URI="https://gitlab.com/latex-rubber/${PN}/-/archive/${PV}/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~ppc ~riscv ~x86"
fi
DESCRIPTION="A LaTeX wrapper for automatically building documents"
@@ -101,8 +100,12 @@ python_install() {
}
src_install() {
- insinto /usr/share/zsh/site-functions
- newins misc/zsh-completion _rubber
-
distutils-r1_src_install
+
+ # Fix file misplacements
+ dodir /usr/share/man/fr
+ mv "${D}"/usr/share/{doc/man-fr,man/fr/man1} || die
+ mv "${D}"/usr/share/{doc/man-en,man/man1} || die
+ dodir /usr/share/doc/${P}
+ mv "${D}"/usr/share/doc/{rubber.*,${P}/} || die
}