summaryrefslogtreecommitdiff
path: root/dev-tex/rail/rail-1.2_p1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tex/rail/rail-1.2_p1.ebuild')
-rw-r--r--dev-tex/rail/rail-1.2_p1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-tex/rail/rail-1.2_p1.ebuild b/dev-tex/rail/rail-1.2_p1.ebuild
new file mode 100644
index 000000000000..a46c1e07fe0c
--- /dev/null
+++ b/dev-tex/rail/rail-1.2_p1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="4"
+
+inherit latex-package
+
+DESCRIPTION="Offers syntax/railroad diagrams"
+HOMEPAGE="http://www.ctan.org/tex-archive/support/rail/"
+SRC_URI="http://mirror.ctan.org/support/${PN}.zip
+ -> ${P}.zip"
+
+LICENSE="LPPL-1.2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+RDEPEND="app-text/texlive"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ sys-devel/bison
+ sys-devel/flex"
+
+S=${WORKDIR}/${PN}
+
+src_compile() {
+ emake -j 1 || die "make failed"
+}
+
+src_install() {
+ latex-package_src_doinstall sty doc
+
+ dobin rail || die "Installing the rail tool failed"
+
+ newman rail.man rail.1 || die "Installing the manpage failed"
+}