summaryrefslogtreecommitdiff
path: root/dev-tex/dvi2tty/dvi2tty-5.3.4-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tex/dvi2tty/dvi2tty-5.3.4-r1.ebuild')
-rw-r--r--dev-tex/dvi2tty/dvi2tty-5.3.4-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-tex/dvi2tty/dvi2tty-5.3.4-r1.ebuild b/dev-tex/dvi2tty/dvi2tty-5.3.4-r1.ebuild
new file mode 100644
index 000000000000..1645a6ca1c2c
--- /dev/null
+++ b/dev-tex/dvi2tty/dvi2tty-5.3.4-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Preview dvi-files on text-only devices"
+HOMEPAGE="http://www.ctan.org/tex-archive/dviware/"
+SRC_URI="ftp://ftp.mesa.nl/pub/dvi2tty/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux"
+
+src_prepare() {
+ default
+ eapply "${FILESDIR}"/${P}-cflags.patch
+}
+
+src_compile() {
+ tc-export CC
+ emake
+}
+
+src_install() {
+ dobin dvi2tty disdvi
+ doman dvi2tty.1 disdvi.1
+ dodoc README TODO
+}