summaryrefslogtreecommitdiff
path: root/dev-tex/dot2tex
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tex/dot2tex')
-rw-r--r--dev-tex/dot2tex/Manifest2
-rw-r--r--dev-tex/dot2tex/dot2tex-2.11.3.ebuild24
2 files changed, 20 insertions, 6 deletions
diff --git a/dev-tex/dot2tex/Manifest b/dev-tex/dot2tex/Manifest
index b8fef6ff15dc..20c84d62cdc9 100644
--- a/dev-tex/dot2tex/Manifest
+++ b/dev-tex/dot2tex/Manifest
@@ -1,3 +1,3 @@
DIST dot2tex-2.11.3.tar.gz 664750 BLAKE2B 9c7effeca0d71810ce37e126df9e7df2b9df19be41393916c85e49df0dc116f42e58a2b29cce9e2bac700fa00859c63c1a4a8c41c70a9db96a5fc210960f463b SHA512 1595299811461b18cff490a8a56c0215f46989dd4a46fa087b455c717ed5d5f7a5782d04acaa3e4567b4e348bca866d5f24d21663012c4cd813445804ef6f714
-EBUILD dot2tex-2.11.3.ebuild 1004 BLAKE2B 30c25c86050d0ed970422538c9dc6ccd9875c3e03d8c79bc1100e418ef6f92c93ed3c9e31cdb40eb3de18f2778a2071f3b39c845fdcbc3b8332d1c070045feaf SHA512 eb6db1dbdbbd5c9b055a92e02a68e84f437aaa3a2d2b9c93e4b1157e649854fefae86af1fc8a84a43edca475e11208d7053e7f5d5bc0caa501b5257d7fced32f
+EBUILD dot2tex-2.11.3.ebuild 1419 BLAKE2B be14a9045bae2e618e542633af972836a7f04e8085cec47cbeafbce26c444b6816f04df830457260a5a03fe27b064e9c5d54d25c80997b5689bc15701b1ee82d SHA512 839e74ad7198bd95ea48e03ca8124b048c093199871cb937401dcb089429a80837ddde5a1fd25c6f54dd9d14df142a5cbbe67a9bec3ffe014ee8d1dff4efc9fc
MISC metadata.xml 406 BLAKE2B 291c75db88e182c475c71cc7b42782d06c135989e4af7bc64e8efb2b11641e8913f180e0942450c7f1d2117c47c56715b0e20de79d091dca42fa547c33b1a8f5 SHA512 f410fa09db124d2c886471b8cc22f22296f411f9646c9ba02ae4b553d3be88b447ac3ea6c4b2f989b503754c8051911566c2c2cc74d1b2a2b79bf43862e0a0e3
diff --git a/dev-tex/dot2tex/dot2tex-2.11.3.ebuild b/dev-tex/dot2tex/dot2tex-2.11.3.ebuild
index 1e00e0e22341..f35891abaa5e 100644
--- a/dev-tex/dot2tex/dot2tex-2.11.3.ebuild
+++ b/dev-tex/dot2tex/dot2tex-2.11.3.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..9} )
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="A Graphviz to LaTeX converter"
@@ -20,8 +19,23 @@ DEPEND="dev-python/pyparsing[${PYTHON_USEDEP}]"
RDEPEND="
dev-python/pydot[${PYTHON_USEDEP}]
media-gfx/graphviz"
-DEPEND="${DEPEND}
- doc? ( dev-python/sphinx )"
+DEPEND="${DEPEND}"
+BDEPEND="doc? ( dev-python/sphinx )"
+
+EPYTEST_DESELECT=(
+ # https://github.com/kjellmf/dot2tex/issues/94
+ tests/test_dot2tex.py::MultipleStatements::test_semicolon
+)
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Syntax failures (old-style print)
+ # Looks fixed in master: https://github.com/kjellmf/dot2tex/commit/38aeef9615f90fe347c5c45d514eaf00b116422b
+ rm -r "${S}"/tests/experimental || die
+
+ distutils-r1_python_prepare_all
+}
python_compile_all() {
if use doc ; then