summaryrefslogtreecommitdiff
path: root/dev-tex/chktex/chktex-1.7.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tex/chktex/chktex-1.7.6.ebuild')
-rw-r--r--dev-tex/chktex/chktex-1.7.6.ebuild33
1 files changed, 17 insertions, 16 deletions
diff --git a/dev-tex/chktex/chktex-1.7.6.ebuild b/dev-tex/chktex/chktex-1.7.6.ebuild
index e6f58879d684..9edd1bcc2f1d 100644
--- a/dev-tex/chktex/chktex-1.7.6.ebuild
+++ b/dev-tex/chktex/chktex-1.7.6.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
-AUTOTOOLS_AUTORECONF=true
+EAPI=7
-inherit autotools-utils
+inherit autotools
DESCRIPTION="Checks latex source for common mistakes"
HOMEPAGE="http://www.nongnu.org/chktex/"
@@ -12,22 +11,25 @@ SRC_URI="http://download.savannah.gnu.org/releases/chktex/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+KEYWORDS="alpha amd64 arm arm64 ~hppa ia64 ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
IUSE="debug doc +pcre test"
+RESTRICT="!test? ( test )"
# Tests fail without pcre. Enable pcre by default and make tests depend on it.
REQUIRED_USE="test? ( pcre )"
-RDEPEND="virtual/latex-base
- dev-lang/perl
- pcre? ( dev-libs/libpcre )"
+RDEPEND="pcre? ( dev-libs/libpcre )"
+
DEPEND="${RDEPEND}
sys-apps/groff
dev-texlive/texlive-fontsrecommended
doc? ( dev-tex/latex2html )"
+BDEPEND="virtual/latex-base
+ dev-lang/perl:="
+
PATCHES=( "${FILESDIR}/${PN}-1.7.1-asneeded.patch"
"${FILESDIR}/tex-inputenc.patch" )
-DOCS=( NEWS )
+
AT_M4DIR="${S}/m4"
src_configure() {
@@ -37,21 +39,20 @@ src_configure() {
$(use_enable debug debug-info)
$(use_enable pcre)
)
- autotools-utils_src_configure
+ econf ${myconfargs[@]}
}
src_compile() {
- autotools-utils_src_compile
- autotools-utils_src_compile ChkTeX.dvi
- use doc && autotools-utils_src_compile html
+ default
+ emake ChkTeX.dvi
+ use doc && emake html
}
src_install() {
+ default
if use doc ; then
- HTML_DOCS=("${AUTOTOOLS_BUILD_DIR}/HTML/ChkTeX/")
- DOCS+=("${AUTOTOOLS_BUILD_DIR}/HTML/ChkTeX.tex")
+ dodoc HTML/ChkTeX.tex
fi
- DOCS+=("${AUTOTOOLS_BUILD_DIR}/ChkTeX.dvi")
- autotools-utils_src_install
+ dodoc ChkTeX.dvi NEWS
doman *.1
}