summaryrefslogtreecommitdiff
path: root/dev-tcltk/togl/togl-2.0-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tcltk/togl/togl-2.0-r2.ebuild')
-rw-r--r--dev-tcltk/togl/togl-2.0-r2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-tcltk/togl/togl-2.0-r2.ebuild b/dev-tcltk/togl/togl-2.0-r2.ebuild
new file mode 100644
index 000000000000..58d12aadd6c7
--- /dev/null
+++ b/dev-tcltk/togl/togl-2.0-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+MY_P=Togl${PV}
+
+DESCRIPTION="A Tk widget for OpenGL rendering"
+HOMEPAGE="http://togl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}-src.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="debug +threads"
+
+RDEPEND="
+ dev-lang/tk
+ virtual/opengl
+ x11-libs/libXmu"
+DEPEND="${RDEPEND}"
+
+# tests directory is missing
+RESTRICT="test"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed \
+ -e 's:-fomit-frame-pointer::g' \
+ -e 's:-O2::g' \
+ -e 's:-pipe::g' \
+ -i configure || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug symbols) \
+ $(use_enable threads)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dohtml doc/*
+ dodoc README*
+}