summaryrefslogtreecommitdiff
path: root/dev-tcltk/tkpng/tkpng-0.9-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tcltk/tkpng/tkpng-0.9-r2.ebuild')
-rw-r--r--dev-tcltk/tkpng/tkpng-0.9-r2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-tcltk/tkpng/tkpng-0.9-r2.ebuild b/dev-tcltk/tkpng/tkpng-0.9-r2.ebuild
new file mode 100644
index 000000000000..a68fa63effe1
--- /dev/null
+++ b/dev-tcltk/tkpng/tkpng-0.9-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_P="${PN}${PV}"
+
+inherit autotools
+
+DESCRIPTION="Implements support for loading and using PNG images with Tcl/Tk"
+HOMEPAGE="http://www.muonics.com/FreeStuff/TkPNG/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/${PV}/${MY_P}.tgz"
+
+LICENSE="tcltk"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug threads"
+
+RDEPEND="
+ >=dev-lang/tcl-8.4:=
+ >=dev-lang/tk-8.4:=
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}"
+
+# test target in Makefile, but test not shipped
+RESTRICT="test"
+
+S="${WORKDIR}"/${MY_P}
+
+src_prepare() {
+ default
+
+ # Clang 16
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug symbols) \
+ $(use_enable amd64 64bit) \
+ $(use_enable threads)
+}