summaryrefslogtreecommitdiff
path: root/dev-tcltk/tkpng/tkpng-0.9-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tcltk/tkpng/tkpng-0.9-r1.ebuild')
-rw-r--r--dev-tcltk/tkpng/tkpng-0.9-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-tcltk/tkpng/tkpng-0.9-r1.ebuild b/dev-tcltk/tkpng/tkpng-0.9-r1.ebuild
new file mode 100644
index 000000000000..e38d65c8ca05
--- /dev/null
+++ b/dev-tcltk/tkpng/tkpng-0.9-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P="${PN}${PV}"
+
+DESCRIPTION="Implements support for loading and using PNG images with Tcl/Tk"
+HOMEPAGE="http://www.muonics.com/FreeStuff/TkPNG/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/${PV}/${MY_P}.tgz"
+
+SLOT="0"
+LICENSE="tcltk"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug threads"
+
+RDEPEND="
+ >=dev-lang/tcl-8.4:0=
+ >=dev-lang/tk-8.4:0=
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+# test target in Makefile, but test not shipped
+RESTRICT="test"
+
+S="${WORKDIR}"/${MY_P}
+
+src_configure() {
+ econf \
+ $(use_enable debug symbols) \
+ $(use_enable amd64 64bit) \
+ $(use_enable threads)
+}