summaryrefslogtreecommitdiff
path: root/dev-tcltk/thread/thread-2.8.9.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tcltk/thread/thread-2.8.9.ebuild')
-rw-r--r--dev-tcltk/thread/thread-2.8.9.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-tcltk/thread/thread-2.8.9.ebuild b/dev-tcltk/thread/thread-2.8.9.ebuild
new file mode 100644
index 000000000000..d17e1037fa84
--- /dev/null
+++ b/dev-tcltk/thread/thread-2.8.9.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_P="${PN}-$(ver_rs 0- '-')"
+
+DESCRIPTION="Tcl Thread extension"
+HOMEPAGE="http://www.tcl.tk/"
+SRC_URI="https://github.com/tcltk/${PN}/archive/refs/tags/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+DEPEND="dev-lang/tcl:0=[threads]"
+RDEPEND="${DEPEND}"
+
+QA_CONFIG_IMPL_DECL_SKIP=(
+ opendir64 rewinddir64 closedir64 stat64 # used to test for Large File Support on AIX
+)
+
+S="${WORKDIR}"/${PN}-${MY_P}
+
+PATCHES=( "${FILESDIR}"/${PN}-2.8.5-musl.patch )
+
+src_configure() {
+ econf --with-tclinclude="${EPREFIX}/usr/include" \
+ --with-tcl="${EPREFIX}/usr/$(get_libdir)"
+}