summaryrefslogtreecommitdiff
path: root/dev-scheme/skribilo
diff options
context:
space:
mode:
Diffstat (limited to 'dev-scheme/skribilo')
-rw-r--r--dev-scheme/skribilo/Manifest4
-rw-r--r--dev-scheme/skribilo/files/50skribilo-gentoo.el3
-rw-r--r--dev-scheme/skribilo/metadata.xml21
-rw-r--r--dev-scheme/skribilo/skribilo-0.9.5.ebuild78
4 files changed, 106 insertions, 0 deletions
diff --git a/dev-scheme/skribilo/Manifest b/dev-scheme/skribilo/Manifest
new file mode 100644
index 000000000000..e8605103d902
--- /dev/null
+++ b/dev-scheme/skribilo/Manifest
@@ -0,0 +1,4 @@
+AUX 50skribilo-gentoo.el 116 BLAKE2B 1b699d8a6965131650d6d46cd5d2f0280a6cb0c781194adf48b708fd826cc8f94c8d3e1109766e3966e26f161cd12e89f2cc61bd7a3cb0bdbf74051866cfa467 SHA512 f8cb01127dfcdf8f5c88a4c928f2f80db70a40f03166744d3a7989b34a6d4cf92e1815da329f64dccf7ea6fa1d489744a786f04e7f34fbee654bb80294e81356
+DIST skribilo-0.9.5.tar.gz 1520763 BLAKE2B c624174a29cb7eb7236b8de506ade00c58fdd895807bd3e052872b7d950be9106daef6015c34ff8b5e7888b43383cbfa5c29c62835d02121cac19062985c6032 SHA512 22dff4523039792bd3662f9f1302569bfb83d92b7106ae22b8926e264b00932ea50ab753bb83aed499d0aa651d0fe99fdfd28b83956ec3ad84b81078391fe014
+EBUILD skribilo-0.9.5.ebuild 1505 BLAKE2B b6c84dd3e5c5e33b14bf8e7d86222959af418c6a83d5f1c493106db3e9600fe1d0ceb06ab331ee30edb319f1e0ef9a59eca1c30fe30a0da17a045cf73982c019 SHA512 3660956df88e8a50f4c889b11c6f959dd2aca665823f7a71776bb763dea4fed47fa970565793684c9f21a46130da87ac495f1e3c7179e34c71ef4487497b3e12
+MISC metadata.xml 968 BLAKE2B d503b255bcca3c11002b1a09dafb983742b0e9610be1c4361c764fbe3edcd5c85ba60a9157825ce7f8e95bf73066bb8204d45d4fad372c36cadb14d9b237da3f SHA512 254374cdbc550ab09b684670adedc14dbdb29c95741d030959a3b07d830056561be40b4874def164688a2d7d2afa0474eb27ec17348717363e08351ad4660cfa
diff --git a/dev-scheme/skribilo/files/50skribilo-gentoo.el b/dev-scheme/skribilo/files/50skribilo-gentoo.el
new file mode 100644
index 000000000000..b6dc5061ebfd
--- /dev/null
+++ b/dev-scheme/skribilo/files/50skribilo-gentoo.el
@@ -0,0 +1,3 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'skribe-mode "skribe"
+ "Minor mode for editing Skribe sources." t)
diff --git a/dev-scheme/skribilo/metadata.xml b/dev-scheme/skribilo/metadata.xml
new file mode 100644
index 000000000000..24602493b44a
--- /dev/null
+++ b/dev-scheme/skribilo/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>scheme@gentoo.org</email>
+ <name>Gentoo Scheme Project</name>
+ </maintainer>
+ <longdescription>
+ Skribilo is a free document production tool that takes a structured
+ document representation as its input and renders that document in a variety
+ of output formats: HTML and Info for on-line browsing, and Lout and LaTeX
+ for high-quality hard copies.
+ The input document can use Skribilo's markup language to provide
+ information about the document's structure, which is similar to HTML or
+ LaTeX and does not require expertise. Alternatively, it can use a simpler,
+ "markup-less" format that borrows from Emacs' outline mode and from other
+ conventions used in emails, Usenet and text.
+ Lastly, Skribilo provides Guile Scheme APIs.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-scheme/skribilo/skribilo-0.9.5.ebuild b/dev-scheme/skribilo/skribilo-0.9.5.ebuild
new file mode 100644
index 000000000000..fa72296a9295
--- /dev/null
+++ b/dev-scheme/skribilo/skribilo-0.9.5.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp-common
+
+DESCRIPTION="Document production tool written in Guile Scheme"
+HOMEPAGE="https://www.nongnu.org/skribilo/"
+SRC_URI="mirror://nongnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="emacs"
+RESTRICT="strip test" # tests fail, seem broken
+
+RDEPEND="
+ app-text/ghostscript-gpl
+ media-gfx/imagemagick
+
+ >=dev-scheme/guile-2.0.0:=
+ dev-scheme/guile-lib
+ dev-scheme/guile-reader
+"
+DEPEND="${RDEPEND}"
+BDEPEND="emacs? ( >=app-editors/emacs-23.1:* )"
+
+# guile generates ELF files without use of C or machine code
+# It's a portage's false positive. bug #677600
+QA_PREBUILT='*[.]go'
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ default
+
+ # http://debbugs.gnu.org/cgi/bugreport.cgi?bug=38112
+ find "${S}" -name "*.scm" -exec touch {} + || die
+}
+
+src_configure() {
+ if ! use emacs ; then
+ export EMACS="no"
+ export EMACSLOADPATH="/dev/null"
+ fi
+
+ econf
+}
+
+src_compile() {
+ default
+
+ use emacs && elisp-compile ./emacs/*.el
+}
+
+src_install() {
+ default
+
+ if use emacs ; then
+ elisp-install ${PN} ./emacs/*.el{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ else
+ local emacsd="${D}"/usr/share/emacs
+ if [[ -d "${emacsd}" ]] ; then
+ echo "Building without Emacs support but ${emacsd} found! Removing."
+ rm -r "${emacsd}" || die
+ fi
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}