summaryrefslogtreecommitdiff
path: root/dev-scheme/guile-git/guile-git-0.5.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-scheme/guile-git/guile-git-0.5.2.ebuild')
-rw-r--r--dev-scheme/guile-git/guile-git-0.5.2.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/dev-scheme/guile-git/guile-git-0.5.2.ebuild b/dev-scheme/guile-git/guile-git-0.5.2.ebuild
index e1f491fe31d8..2aac37120828 100644
--- a/dev-scheme/guile-git/guile-git-0.5.2.ebuild
+++ b/dev-scheme/guile-git/guile-git-0.5.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -19,7 +19,7 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
# Works without sandbox. But under sandbox sshd claims to break the protocol.
-RESTRICT="strip test"
+RESTRICT="test"
# older libgit seems to be incompatible with guile-git bindings
# https://github.com/trofi/nix-guix-gentoo/issues/7
@@ -52,3 +52,11 @@ src_prepare() {
src_test() {
emake check VERBOSE=1
}
+
+src_install() {
+ default
+
+ # Workaround llvm-strip problem of mangling guile ELF debug
+ # sections: https://bugs.gentoo.org/905898
+ dostrip -x "/usr/$(get_libdir)/guile"
+}