summaryrefslogtreecommitdiff
path: root/dev-scheme/guile-gcrypt/guile-gcrypt-0.3.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-scheme/guile-gcrypt/guile-gcrypt-0.3.0.ebuild')
-rw-r--r--dev-scheme/guile-gcrypt/guile-gcrypt-0.3.0.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/dev-scheme/guile-gcrypt/guile-gcrypt-0.3.0.ebuild b/dev-scheme/guile-gcrypt/guile-gcrypt-0.3.0.ebuild
index d0b486243328..925cd6308503 100644
--- a/dev-scheme/guile-gcrypt/guile-gcrypt-0.3.0.ebuild
+++ b/dev-scheme/guile-gcrypt/guile-gcrypt-0.3.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -13,8 +13,6 @@ S="${WORKDIR}/${PN}"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-RESTRICT="strip"
RDEPEND="
>=dev-scheme/guile-2.0.11:=
@@ -35,3 +33,11 @@ src_prepare() {
# upstream tag on top of source tree. has no autogenerated files
eautoreconf
}
+
+src_install() {
+ default
+
+ # Workaround llvm-strip problem of mangling guile ELF debug
+ # sections: https://bugs.gentoo.org/905898
+ dostrip -x "/usr/$(get_libdir)/guile"
+}