summaryrefslogtreecommitdiff
path: root/dev-scheme/guile-config/guile-config-0.5.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-scheme/guile-config/guile-config-0.5.1.ebuild')
-rw-r--r--dev-scheme/guile-config/guile-config-0.5.1.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/dev-scheme/guile-config/guile-config-0.5.1.ebuild b/dev-scheme/guile-config/guile-config-0.5.1.ebuild
index 45adef20bac6..c1144e43ef4b 100644
--- a/dev-scheme/guile-config/guile-config-0.5.1.ebuild
+++ b/dev-scheme/guile-config/guile-config-0.5.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -12,7 +12,6 @@ SRC_URI="https://gitlab.com/a-sassmannshausen/${PN}/-/archive/${PV}/${P}.tar.bz2
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-RESTRICT="strip"
RDEPEND=">=dev-scheme/guile-2.0.0:="
DEPEND="${RDEPEND}"
@@ -29,3 +28,11 @@ src_prepare() {
eautoreconf
}
+
+src_install() {
+ default
+
+ # Workaround llvm-strip problem of mangling guile ELF debug
+ # sections. Bug https://bugs.gentoo.org/905898
+ dostrip -x /usr/$(get_libdir)/guile
+}