summaryrefslogtreecommitdiff
path: root/dev-scheme/c-wrapper/c-wrapper-0.6.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-scheme/c-wrapper/c-wrapper-0.6.1.ebuild')
-rw-r--r--dev-scheme/c-wrapper/c-wrapper-0.6.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-scheme/c-wrapper/c-wrapper-0.6.1.ebuild b/dev-scheme/c-wrapper/c-wrapper-0.6.1.ebuild
new file mode 100644
index 000000000000..e20f77d0d1fa
--- /dev/null
+++ b/dev-scheme/c-wrapper/c-wrapper-0.6.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit autotools eutils
+
+DESCRIPTION="Foreign function interface for C and Objective-C libraries"
+HOMEPAGE="http://www.koguro.net/prog/c-wrapper/"
+SRC_URI="http://www.koguro.net/prog/${PN}/${P}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="examples"
+
+RDEPEND="dev-scheme/gauche
+ virtual/libffi"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-system-libffi.diff
+ eautoreconf
+}
+
+src_test() {
+ emake -j1 -s check
+}
+
+src_install() {
+ default
+ dohtml doc/*
+
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples
+ dodoc -r examples
+ fi
+}