summaryrefslogtreecommitdiff
path: root/dev-scheme/akku/akku-1.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-scheme/akku/akku-1.1.0.ebuild')
-rw-r--r--dev-scheme/akku/akku-1.1.0.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/dev-scheme/akku/akku-1.1.0.ebuild b/dev-scheme/akku/akku-1.1.0.ebuild
index 76a3f57a10e5..05a618969782 100644
--- a/dev-scheme/akku/akku-1.1.0.ebuild
+++ b/dev-scheme/akku/akku-1.1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -20,7 +20,7 @@ fi
LICENSE="GPL-3+"
SLOT="0"
# tests require network access
-RESTRICT="strip test"
+RESTRICT="test"
RDEPEND="
>=dev-scheme/guile-2.0.11:=
@@ -46,3 +46,12 @@ src_compile() {
emake
}
+
+src_install() {
+ default
+
+ # Workaround llvm-strip problem of mangling guile ELF debug
+ # sections: https://bugs.gentoo.org/905898
+ dostrip -x "/usr/$(get_libdir)/guile"
+ dostrip -x "/usr/$(get_libdir)/akku"
+}