summaryrefslogtreecommitdiff
path: root/dev-ruby
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/Manifest.gzbin106616 -> 106611 bytes
-rw-r--r--dev-ruby/net-http-persistent/Manifest2
-rw-r--r--dev-ruby/net-http-persistent/net-http-persistent-3.1.0.ebuild31
-rw-r--r--dev-ruby/sass-rails/Manifest2
-rw-r--r--dev-ruby/sass-rails/sass-rails-5.0.8.ebuild38
5 files changed, 73 insertions, 0 deletions
diff --git a/dev-ruby/Manifest.gz b/dev-ruby/Manifest.gz
index 3af3cd96f115..f7789fc9106d 100644
--- a/dev-ruby/Manifest.gz
+++ b/dev-ruby/Manifest.gz
Binary files differ
diff --git a/dev-ruby/net-http-persistent/Manifest b/dev-ruby/net-http-persistent/Manifest
index 51066cef8315..d90324c1f27a 100644
--- a/dev-ruby/net-http-persistent/Manifest
+++ b/dev-ruby/net-http-persistent/Manifest
@@ -1,3 +1,5 @@
+DIST net-http-persistent-3.1.0.gem 31744 BLAKE2B fdd9c36ab5216c1cd1fe358207a689276e109845ac374ea16011469b6cb2b165115e78e701cce98c280e7f878c23d8016e75cac4508c7e579209012671b64101 SHA512 65b5afc4ad0729ec14b642e0e36363cecfff3dc25b26308d632866e93fed3eccfb83ce85da78f631553c6a1fe3ee834fcbc9d3681c85db6387463abbc30e60fa
DIST net-http-persistent-4.0.1.gem 27136 BLAKE2B b88151498c401cc20983c86859d7ef7ae3688ee12a5fcc69544d9716c3aeed55f4339d35ec08e9c0a6a16b4b4ab807d7155425c3056b9634185c255472ad93c5 SHA512 d3c86c9c58affac8cde1513dd899527406c0baafd3a620b80011e3babf51a4bfd6fb2bd8998fd9c4696d49aad2d014bdf666b9626e06fe4413cb4010f94e5e91
+EBUILD net-http-persistent-3.1.0.ebuild 867 BLAKE2B ad7768aff4ddfab8295fd4256aedc83284e923b5d3f548029f079673914da92d6b27a2d089abf20ee62ed2cc5ba358373b35b4b2c7e1f3c3d48e575daa0ef3bc SHA512 26f88aac2cfeaa317cc1727031a418e91bb9d8bc54a9df03431338aa67ec60ed049ad3ed4c9d161d5a3951cd11033be1aecc1316d067e68b3e298b850ac7db0b
EBUILD net-http-persistent-4.0.1.ebuild 853 BLAKE2B 5408749826ca05c4a68d1a5c47b99624a947e2c9efaffdcc56593a9d234a6ad1dbfb63b5190c8f4aa61b40bd064fb78cf24af16bc5553809c3035f670795cf1d SHA512 a4115cc2186c4902eda5a6631b5594769d16342ba93db7383be3edbea718454088cf2cad16976e2a55818e64e05a0908f8bff5658bfd0fef8738f0c14e2f0747
MISC metadata.xml 354 BLAKE2B 003bf0e8c6c7665a205d4dc3c58aa7982877e0d3dcad6706d16cea61a2b53381cb10f4bfdc8a482a8d10c7a1279dc42e542f283dd880e8c258eb7e066eebeca8 SHA512 71adf8afebb39564bd527c758e35f048af6066f4e75db8e1a4b8921af94bdd3f017bf9dd092ecf38ed79de63940dd9f0b89020687092db4a919de5d7dc493ccd
diff --git a/dev-ruby/net-http-persistent/net-http-persistent-3.1.0.ebuild b/dev-ruby/net-http-persistent/net-http-persistent-3.1.0.ebuild
new file mode 100644
index 000000000000..13fed6f70af6
--- /dev/null
+++ b/dev-ruby/net-http-persistent/net-http-persistent-3.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Manages persistent connections using Net::HTTP plus a speed fix for Ruby 1.8"
+HOMEPAGE="https://github.com/drbrain/net-http-persistent"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+IUSE="doc test"
+
+ruby_add_rdepend ">=dev-ruby/connection_pool-2.2:0"
+
+ruby_add_bdepend "
+ test? ( dev-ruby/hoe dev-ruby/minitest )"
+
+all_ruby_prepare() {
+ # avoid test with implicit dependency on net-http-pipeline which
+ # fails and is not tested upstream
+ sed -i -e '/net-http-pipeline not installed/ s/unless.*$//' test/test_net_http_persistent.rb || die
+}
diff --git a/dev-ruby/sass-rails/Manifest b/dev-ruby/sass-rails/Manifest
index d877624de071..8da1d0177cc8 100644
--- a/dev-ruby/sass-rails/Manifest
+++ b/dev-ruby/sass-rails/Manifest
@@ -1,3 +1,5 @@
+DIST sass-rails-5.0.8.tar.gz 90020 BLAKE2B 20e9e6e4701b0a14ff10f343fb94065af0110d86aab1bb4676de4806e20f8031b4cf7961002828438c3ae6be9802b3a2e4367882241e8fe745029747d31f9b04 SHA512 05d9e8d269c608723158831e215599a8482383fe79a9c3416fa8efd11bf9bae7935c5b7a1f5e8a22a85336abf4ceecc50578f0c8e51310c09b2540831959652e
DIST sass-rails-5.1.0.tar.gz 89994 BLAKE2B dc0083af8399d2ff1210a6430d47ccaaac88b337da5cfeb61c7a4f0c6b1f55d59d896a874945a943cc322fabfb3a31d80a1a467a12d04f2c1a1f9c84cbb452a0 SHA512 894b957b6b72d340ef2eebdc721c58c2d101fd275a10265f859f17f654736b3d3542a7100db922236925af40ae090406689815a4bb4f623c5f70652685571b7e
+EBUILD sass-rails-5.0.8.ebuild 1063 BLAKE2B 0b7b2824bd31277ce1028080b495480b6e49431141266d461e08e54a6bbafbbf0da22c3712e5d9ed98cc4b4ea89ef728fe8ebe167c4118db57d85bd54a6026a4 SHA512 42d0651e8a5ba3b2cdd51e505cf125558a01bac9880b5dfbf63c528efad45f550ac6822b15116f54993db99c1524b6f0315af9555dc3268bc0b2330cd3d30c06
EBUILD sass-rails-5.1.0.ebuild 1063 BLAKE2B 04cafc02d7915775c326000b5fdf847585a77360367b175fa07236ffb1ddb8a7b400558b02005f424cc7a97c931c5fd38942bb9d1a66e5b45a9ccd919d626d83 SHA512 fcb75b9477ffeef58e15faa293f930570515fdea6c9a38262d4c249df38373611519c6024d1ac585dab93f68ff62aba089d1f58e08b0ab44c4bfafa02b6630f5
MISC metadata.xml 343 BLAKE2B c5a05184557a2483d634a9684fedf6bc5d53522e766510829d3765a937f68dc7b8c887ff82f4e81bdf3e25385d32a043813032beb255a061b51ccb03c094b9c1 SHA512 a2d0d0783101ee59353b76a9557f50876157228c532442184f2ed72ff21286127cc83d0f0040ec6e2927d4ec45b04e891d7f13cf221d1fe09e176ac9896c195d
diff --git a/dev-ruby/sass-rails/sass-rails-5.0.8.ebuild b/dev-ruby/sass-rails/sass-rails-5.0.8.ebuild
new file mode 100644
index 000000000000..f9e3ab5413f8
--- /dev/null
+++ b/dev-ruby/sass-rails/sass-rails-5.0.8.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Official Ruby-on-Rails Integration with Sass"
+HOMEPAGE="https://github.com/rails/sass-rails"
+SRC_URI="https://github.com/rails/sass-rails/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux"
+
+IUSE=""
+
+# Restrict tests for now since it is hard to set up the right
+# environment with the correct ruby interpreter and Rails test
+# application.
+RESTRICT="test"
+
+#ruby_add_bdepend "test? ( dev-ruby/sfl dev-ruby/bundler )"
+
+ruby_add_rdepend ">=dev-ruby/sass-3.1:* =dev-ruby/sass-3*:*
+ >=dev-ruby/railties-5.2.0
+ >=dev-ruby/sprockets-rails-2.0:* <dev-ruby/sprockets-rails-4:*
+ >=dev-ruby/sprockets-2.8:* <dev-ruby/sprockets-4:*
+ >=dev-ruby/tilt-1.1:* <dev-ruby/tilt-3:*"
+
+each_ruby_test() {
+ ${RUBY} -S bundle exec rake test || die
+}