summaryrefslogtreecommitdiff
path: root/dev-ruby/zentest/zentest-4.11.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/zentest/zentest-4.11.0.ebuild')
-rw-r--r--dev-ruby/zentest/zentest-4.11.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-ruby/zentest/zentest-4.11.0.ebuild b/dev-ruby/zentest/zentest-4.11.0.ebuild
new file mode 100644
index 000000000000..279b41748806
--- /dev/null
+++ b/dev-ruby/zentest/zentest-4.11.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_NAME=ZenTest
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.txt History.txt example.txt example1.rb example2.rb example_dot_autotest.rb"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Testing tools: zentest, unit_diff, autotest, multiruby, and Test::Rails"
+HOMEPAGE="https://github.com/seattlerb/zentest"
+LICENSE="Ruby"
+
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/hoe-2.10
+ dev-ruby/hoe-seattlerb
+ dev-ruby/minitest:5
+ )"
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *ruby23)
+ sed -i -e '/test_testcase9/a skip "ruby 2.3 defines more methods"' test/test_zentest.rb || die
+ ;;
+ *)
+ ;;
+ esac
+}