summaryrefslogtreecommitdiff
path: root/dev-ruby/yard/yard-0.8.7.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/yard/yard-0.8.7.3.ebuild')
-rw-r--r--dev-ruby/yard/yard-0.8.7.3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ruby/yard/yard-0.8.7.3.ebuild b/dev-ruby/yard/yard-0.8.7.3.ebuild
new file mode 100644
index 000000000000..385a4f72fd9e
--- /dev/null
+++ b/dev-ruby/yard/yard-0.8.7.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_TASK_DOC="yard"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_DOCDIR="doc docs"
+
+RUBY_FAKEGEM_EXTRAINSTALL="templates"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Documentation generation tool for the Ruby programming language"
+HOMEPAGE="http://yardoc.org/"
+
+# The gem lakes the gemspec file needed to pass tests.
+SRC_URI="https://github.com/lsegal/yard/archive/${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "doc? ( || ( dev-ruby/bluecloth dev-ruby/maruku dev-ruby/rdiscount dev-ruby/kramdown ) )
+ test? ( dev-ruby/rack )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/ s:^:#:' spec/spec_helper.rb || die
+ sed -i -e "s/require 'bundler'; rescue LoadError//" spec/cli/server_spec.rb || die
+}