summaryrefslogtreecommitdiff
path: root/dev-ruby/websocket/websocket-1.2.11.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/websocket/websocket-1.2.11.ebuild')
-rw-r--r--dev-ruby/websocket/websocket-1.2.11.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ruby/websocket/websocket-1.2.11.ebuild b/dev-ruby/websocket/websocket-1.2.11.ebuild
new file mode 100644
index 000000000000..8d4711c1c193
--- /dev/null
+++ b/dev-ruby/websocket/websocket-1.2.11.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Universal Ruby library to handle WebSocket protocol"
+HOMEPAGE="https://github.com/imanel/websocket-ruby"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+IUSE="test"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/rspec-its
+ dev-ruby/webrick
+ )
+"