summaryrefslogtreecommitdiff
path: root/dev-ruby/webmock
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/webmock')
-rw-r--r--dev-ruby/webmock/Manifest1
-rw-r--r--dev-ruby/webmock/webmock-3.14.0-r1.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-ruby/webmock/Manifest b/dev-ruby/webmock/Manifest
index 4edc65afd582..7029b9420ff7 100644
--- a/dev-ruby/webmock/Manifest
+++ b/dev-ruby/webmock/Manifest
@@ -1,3 +1,4 @@
DIST webmock-3.14.0.gem 126976 BLAKE2B 20dd463c8b784869d4379aeabf892a6b4602091a4cc01a4002161d88f24781bb2bae1e50bd0ce8077c40aab73a2243835d99551bd04d808ffdf019df071c2b01 SHA512 0c9ea5b29446de7619c45d0fb72ab305bf68150c9d657ddc223d0d258a400dc730e3fe401b46c994a5c8eb450db5ee8f7021fe8d2d6c85bc4723c657799c5ccc
+EBUILD webmock-3.14.0-r1.ebuild 2201 BLAKE2B 9d40106d688723fc8fd1ad14c3ddbaf54bf283ed99a3cfe81763ced9926bee97390cf02b678751548208752526d8b830bb0cc3a5e2017d8328e4ece4327ed489 SHA512 568d2ef8419c61b64b41c33d902412b7196b57bf038a75f12f5ddb745ac9ab035628d4e25afa6cd6edceff00b5b575b1e86336c6f12235855b26f0d42046e6fe
EBUILD webmock-3.14.0.ebuild 1993 BLAKE2B 3859ccfeb43a7a4a895b2a3c3b49cf1a8c5f0fd5f9dd2374d90393e8c8828a0206e2da676046069560ee6c9526c33e351e7e1271dcdbc4b46ea9f57d21294eac SHA512 03186e23bee7308be8291d9f673f8ab1ba5f1db7f8feceb11a59b1fd7aa60aa3f32052106e946e7b569629c343cd8fef7d0d0ca44eb4299e717ee0000127dad1
MISC metadata.xml 342 BLAKE2B 0f0b9d59bb3519e6da06fe5d57cc9ce3cc1f3a1f516006a3d43a6cd3c416b3b5d9d2955a7800a588010b9672f3a03fb6a74bc62c3ead8b2e0f0b3ce0f5af5456 SHA512 0c4f9ce8deb018a77c7ec77417a22d3b95d0701263acc1ff07081e4e7ef995051ad2eba387962ee06b4bd810db5da7e2294e1ca7bb9a50704f7d7265b8462997
diff --git a/dev-ruby/webmock/webmock-3.14.0-r1.ebuild b/dev-ruby/webmock/webmock-3.14.0-r1.ebuild
new file mode 100644
index 000000000000..d5b431fb5dd2
--- /dev/null
+++ b/dev-ruby/webmock/webmock-3.14.0-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30"
+
+RUBY_FAKEGEM_TASK_TEST="test spec NO_CONNECTION=true"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Allows stubbing HTTP requests and setting expectations on HTTP requests"
+HOMEPAGE="https://github.com/bblimke/webmock"
+
+LICENSE="GPL-2"
+SLOT="3"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/addressable-2.8.0
+ >=dev-ruby/crack-0.3.2
+ >=dev-ruby/hashdiff-0.4.0:0
+"
+
+ruby_add_bdepend "test? (
+ dev-ruby/minitest:5
+ dev-ruby/rspec:3
+ >=dev-ruby/test-unit-3.0.0
+ dev-ruby/rack
+)"
+
+all_ruby_prepare() {
+ # Remove bundler support
+ rm Gemfile || die
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+ sed -i -e '/simplecov/I s:^:#:' spec/spec_helper.rb || die
+ sed -i -e '1igem "test-unit"' test/test_helper.rb || die
+
+ # There is now optional support for curb and typhoeus which we don't
+ # have in Gentoo yet. em_http_request is available in Gentoo but its
+ # version is too old. patron's latest version is not compatible.
+ # httpclient is no longer maintained and has various test failures.
+ sed -i -e '/\(curb\|typhoeus\|em-http\|patron\|httpclient\)/ s:^:#:' spec/spec_helper.rb || die
+ rm -f spec/acceptance/{typhoeus,curb,excon,em_http_request,patron,async_http_client,httpclient}/* || die
+
+ # Drop tests for dev-ruby/http for now since this package only works with ruby26
+ sed -i -e '/http_rb/ s:^:#:' spec/spec_helper.rb || die
+ rm -f spec/acceptance/http_rb/* || die
+
+ # Avoid specs that require network access
+ sed -i -e '/when request is not stubbed/,/^ end/ s:^:#:' spec/acceptance/shared/callbacks.rb
+
+ # Fix specs with kwargs confusion on ruby30
+ sed -i -e "21 s/'A' => 'a'/{'A' => 'a'}/" spec/unit/request_signature_spec.rb || die
+ sed -i -e "34 s/'A' => 'a'/{'A' => 'a'}/" spec/unit/response_spec.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -S rake test NO_CONNECTION=true || die
+ ${RUBY} -S rspec-3 spec || die
+
+ einfo "Delay to allow the test server to stop"
+ sleep 10
+}