summaryrefslogtreecommitdiff
path: root/dev-ruby/vlad/vlad-2.7.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/vlad/vlad-2.7.0.ebuild')
-rw-r--r--dev-ruby/vlad/vlad-2.7.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/vlad/vlad-2.7.0.ebuild b/dev-ruby/vlad/vlad-2.7.0.ebuild
new file mode 100644
index 000000000000..2ebe83b42461
--- /dev/null
+++ b/dev-ruby/vlad/vlad-2.7.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="considerations.txt History.txt README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Pragmatic application deployment automation, without mercy"
+HOMEPAGE="https://github.com/seattlerb/vlad"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_bdepend ">=dev-ruby/hoe-3.13
+ test? ( >=dev-ruby/minitest-5.7 )"
+ruby_add_rdepend ">=dev-ruby/rake-remote_task-2.3"
+
+all_ruby_prepare() {
+ # Keep Isolate from managing the dependencies.
+ sed -i -e '/isolate/ s:^:#:' -e '/rubyforge/ s:^:#:' Rakefile || die
+}