summaryrefslogtreecommitdiff
path: root/dev-ruby/vcard/vcard-0.2.16.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/vcard/vcard-0.2.16.ebuild')
-rw-r--r--dev-ruby/vcard/vcard-0.2.16.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/vcard/vcard-0.2.16.ebuild b/dev-ruby/vcard/vcard-0.2.16.ebuild
new file mode 100644
index 000000000000..fab4526db1a1
--- /dev/null
+++ b/dev-ruby/vcard/vcard-0.2.16.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25 ruby26"
+
+# Avoid the complexity of the "rake" recipe and run testrb-2 manually.
+RUBY_FAKEGEM_RECIPE_TEST=none
+RUBY_FAKEGEM_RECIPE_DOC=none
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby vcard support extracted from Vpim"
+HOMEPAGE="https://github.com/qoobaa/vcard"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2 )"
+
+each_ruby_test() {
+ ruby-ng_testrb-2 --load-path=lib --pattern='.*_test\.rb' test/
+}