summaryrefslogtreecommitdiff
path: root/dev-ruby/tzinfo/tzinfo-1.2.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/tzinfo/tzinfo-1.2.5.ebuild')
-rw-r--r--dev-ruby/tzinfo/tzinfo-1.2.5.ebuild3
1 files changed, 3 insertions, 0 deletions
diff --git a/dev-ruby/tzinfo/tzinfo-1.2.5.ebuild b/dev-ruby/tzinfo/tzinfo-1.2.5.ebuild
index 1b36cf383f93..37433640300f 100644
--- a/dev-ruby/tzinfo/tzinfo-1.2.5.ebuild
+++ b/dev-ruby/tzinfo/tzinfo-1.2.5.ebuild
@@ -29,4 +29,7 @@ ruby_add_bdepend "test? ( dev-ruby/minitest:5 )"
all_ruby_prepare() {
# Set the secure permissions that tests expect.
chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+
+ # Avoid taint tests that throw SecurityErrors on newer ruby versions.
+ sed -i -e '/_info_tainted/askip"SecurityError"' test/tc_ruby_data_source.rb || die
}