summaryrefslogtreecommitdiff
path: root/dev-ruby/typed-array/typed-array-0.1.2-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/typed-array/typed-array-0.1.2-r2.ebuild')
-rw-r--r--dev-ruby/typed-array/typed-array-0.1.2-r2.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-ruby/typed-array/typed-array-0.1.2-r2.ebuild b/dev-ruby/typed-array/typed-array-0.1.2-r2.ebuild
index c0025e9f5408..5e00a48f8e06 100644
--- a/dev-ruby/typed-array/typed-array-0.1.2-r2.ebuild
+++ b/dev-ruby/typed-array/typed-array-0.1.2-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -7,7 +7,7 @@ RUBY_FAKEGEM_DOCDIR="doc"
RUBY_FAKEGEM_EXTRADOC="README.rdoc"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+USE_RUBY="ruby30 ruby31 ruby32"
inherit ruby-fakegem
DESCRIPTION="Gem provides enforced-type functionality to Arrays"
@@ -21,4 +21,6 @@ IUSE=""
all_ruby_prepare() {
# There is a trash...
rm "${S}"/lib/typed-array/.DS_Store || die
+
+ sed -i -e 's/Fixnum/Integer/' spec/typed-array_spec.rb || die
}