summaryrefslogtreecommitdiff
path: root/dev-ruby/tty-command
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/tty-command')
-rw-r--r--dev-ruby/tty-command/Manifest2
-rw-r--r--dev-ruby/tty-command/tty-command-0.10.0.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/tty-command/Manifest b/dev-ruby/tty-command/Manifest
index 1df254542fe0..d3d280952ecc 100644
--- a/dev-ruby/tty-command/Manifest
+++ b/dev-ruby/tty-command/Manifest
@@ -1,3 +1,5 @@
+DIST tty-command-0.10.0.tar.gz 31592 BLAKE2B 34bb5a926ad32b236585a3e0d5bcfebc6a7d8b3ab3c63e60db30441f6f66b757260b35b40fe5e22ec96162253716d27111c0def59133e80c9dabbaf5f87f68da SHA512 5397f154603b1516be717ac35665623292d1454c18824cc688227f998c8d14e0744fc143e29dd93e737ae78f1800a1e5812ed6cbacb0df6ac4db28b2f096fcde
DIST tty-command-0.9.0.tar.gz 30463 BLAKE2B fc0436a80b4b73040a89f085315f50e464efd91d6ee222f7b94eec5b94700089ae22963580febf8296377c859c67f1f21772ecd24d325af76308183df6070e2a SHA512 12c5c238ea34b7236b1c1b3115a7f490ae3986de686359ed390428f766aabdb35de7a1b29363b5be4e09e0fb6888b0c8a30eb466153f64b1d8a77620a657ffac
+EBUILD tty-command-0.10.0.ebuild 717 BLAKE2B 2f73b05720fd1a712cead3132c7c7a23a41e47782fb239d25bf170f560810a11e2c439050f0ee4a85cd69c0a3f8c666b0ea7e470aa202c7ba16bd323160ce17c SHA512 b0c1c88ca136e4c4d408792a3fca7c8b677697eed0af2d4795f6c8180dc54fe7d0a2309d3a21ce2eeb92c5685e998d132211bfffdef2f83d189bb56b5dc8d82c
EBUILD tty-command-0.9.0.ebuild 650 BLAKE2B ffcf3580c5547c80cbce0cda9f26aa8c169c712d00a1c6fa283fe19a8b977bc41bea18a800d1cdd701497e9e96d9a7c4299676eea45a1fe8690825ef8cc67e1c SHA512 d6fdd92c8a3ff6b4b291029d3130c0325ffc139e6144086cf829d7e60b39a452f550c63bb14564efab6b4ef1a91b4a3e0effc6e6cbcce9a17000088d8c497933
MISC metadata.xml 339 BLAKE2B ee77cccbd6cbd65ca83cbca745047dd8ee4d0ec6e955cbc2238b0d403c9c65815ceda7737f70f05a6f01305639b13cb339509a03a7ccf93cde1c643850cc8472 SHA512 1d76e3ee88423ffcc2902c658e434afc2d6a42464f98a651a563441b76d5a236072f4324d7a2f7fe67e6061c6d4ae9cee00af26e1e7519d4ac428e07f11d3c03
diff --git a/dev-ruby/tty-command/tty-command-0.10.0.ebuild b/dev-ruby/tty-command/tty-command-0.10.0.ebuild
new file mode 100644
index 000000000000..861340515246
--- /dev/null
+++ b/dev-ruby/tty-command/tty-command-0.10.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Terminal color capabilities detection"
+HOMEPAGE="https://github.com/piotrmurach/tty-command"
+SRC_URI="https://github.com/piotrmurach/tty-command/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/pastel-0.8:0"
+
+all_ruby_prepare() {
+ echo '-rspec_helper' > .rspec || die
+
+ sed -i -e 's:_relative ": "./:' ${RUBY_FAKEGEM_GEMSPEC} || die
+}