summaryrefslogtreecommitdiff
path: root/dev-ruby/trollop/trollop-1.16.2-r4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/trollop/trollop-1.16.2-r4.ebuild')
-rw-r--r--dev-ruby/trollop/trollop-1.16.2-r4.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ruby/trollop/trollop-1.16.2-r4.ebuild b/dev-ruby/trollop/trollop-1.16.2-r4.ebuild
new file mode 100644
index 000000000000..4c4f499c3261
--- /dev/null
+++ b/dev-ruby/trollop/trollop-1.16.2-r4.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="FAQ.txt History.txt README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Trollop is a commandline option parser for Ruby"
+HOMEPAGE="http://trollop.rubyforge.org/"
+LICENSE="Ruby"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+each_ruby_test() {
+ ${RUBY} -I lib test/test_trollop.rb || die "Tests failed."
+}