summaryrefslogtreecommitdiff
path: root/dev-ruby/timers/timers-4.3.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/timers/timers-4.3.2.ebuild')
-rw-r--r--dev-ruby/timers/timers-4.3.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/timers/timers-4.3.2.ebuild b/dev-ruby/timers/timers-4.3.2.ebuild
new file mode 100644
index 000000000000..33868f0c914d
--- /dev/null
+++ b/dev-ruby/timers/timers-4.3.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="timers.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Pure Ruby one-shot and periodic timers"
+HOMEPAGE="https://github.com/tarcieri/timers"
+SRC_URI="https://github.com/tarcieri/timers/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="4"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e 's:_relative ": "./:' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ sed -i -e '/bundler/I s:^:#:' spec/spec_helper.rb || die
+ sed -i -e '/covered/ s:^:#:' spec/spec_helper.rb || die
+
+ # Avoid performance specs to avoid ruby-prof dependency and
+ # because we cannot provide a good environment for performance testing.
+ rm -f spec/timers/performance_spec.rb || die
+}