summaryrefslogtreecommitdiff
path: root/dev-ruby/thread_safe/thread_safe-0.3.6-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/thread_safe/thread_safe-0.3.6-r1.ebuild')
-rw-r--r--dev-ruby/thread_safe/thread_safe-0.3.6-r1.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-ruby/thread_safe/thread_safe-0.3.6-r1.ebuild b/dev-ruby/thread_safe/thread_safe-0.3.6-r1.ebuild
deleted file mode 100644
index bcc0f770bcd4..000000000000
--- a/dev-ruby/thread_safe/thread_safe-0.3.6-r1.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-USE_RUBY="ruby27 ruby30 ruby31 ruby32"
-
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A collection of thread-safe versions of common core Ruby classes"
-HOMEPAGE="https://github.com/ruby-concurrency/thread_safe"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 arm ~arm64 ~hppa ppc ppc64 ~riscv ~s390 ~sparc x86 ~amd64-linux ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE=""
-
-# Higher atomic dependency since earlier versions crash on ruby20 while
-# running thread_safe tests.
-ruby_add_bdepend "test? ( >=dev-ruby/atomic-1.1.16 )"
-
-each_ruby_prepare() {
- sed -i -e "/[Bb]undler/d" Rakefile || die
- sed -i -e '/coveralls/I s:^:#:' \
- -e '/simplecov/ s:^:#:' \
- -e '/SimpleCov/,/^end/ s:^:#:' spec/spec_helper.rb || die
-}
-
-each_ruby_test() {
- einfo "The test suite may take up to 10 minutes to run without apparent feedback"
- each_fakegem_test
-}