summaryrefslogtreecommitdiff
path: root/dev-ruby/thread_order/thread_order-1.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/thread_order/thread_order-1.1.0.ebuild')
-rw-r--r--dev-ruby/thread_order/thread_order-1.1.0.ebuild28
1 files changed, 0 insertions, 28 deletions
diff --git a/dev-ruby/thread_order/thread_order-1.1.0.ebuild b/dev-ruby/thread_order/thread_order-1.1.0.ebuild
deleted file mode 100644
index 5575df3e8109..000000000000
--- a/dev-ruby/thread_order/thread_order-1.1.0.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-USE_RUBY="ruby22 ruby23 ruby24 ruby25"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_EXTRADOC="Readme.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Test helper for ordering threaded code"
-HOMEPAGE="https://github.com/JoshCheek/thread_order"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-all_ruby_prepare() {
- # Avoid failing spec that already has exceptions for some ruby
- # implementations and is not essential.
- sed -i -e '/depending on the stdlib/,/^ end/ s:^:#:' \
- spec/thread_order_spec.rb || die
-}