summaryrefslogtreecommitdiff
path: root/dev-ruby/text-hyphen
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/text-hyphen')
-rw-r--r--dev-ruby/text-hyphen/Manifest3
-rw-r--r--dev-ruby/text-hyphen/metadata.xml8
-rw-r--r--dev-ruby/text-hyphen/text-hyphen-1.4.1-r2.ebuild29
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-ruby/text-hyphen/Manifest b/dev-ruby/text-hyphen/Manifest
new file mode 100644
index 000000000000..4e3e2538d729
--- /dev/null
+++ b/dev-ruby/text-hyphen/Manifest
@@ -0,0 +1,3 @@
+DIST text-hyphen-1.4.1.gem 751616 BLAKE2B 4a6d6a9b430c2dee2a486dde9f49405b98bc32fe8f96448c0cbe8d55f416c4e4e9bef5ae3adb57576dee6fa285680fc57b958cb279786872c8d95282cbf72e73 SHA512 4a6667aff01e56afce79302f46d0afdbf9c965ad80dbf9a7266a213143e6b6bc2cb00092d26900286bf72a700e47be6b0860cfdf87fa2856477db02261f9ef3d
+EBUILD text-hyphen-1.4.1-r2.ebuild 740 BLAKE2B a3ecc9d342c0d1fda1b471a05af34d84a35926efc7d900c2c40daa368b5767ff5c0e02a78f4217c65ab96da25b087f12b3b81a3d095f9c254852ccc170175c05 SHA512 3ff7a752729affc7bdaa354d251e2d5e021a7b0081bd1a5080ee4cea701a46ed1afd137d6b2c3163952f57a024bf52e765958f592e4dd87d617ddebaa2db56f2
+MISC metadata.xml 251 BLAKE2B e8bf2b70161d425791d65052583fd8be03b19ef3bb2a2cde34605bc93224fea9d8c6a91f0f2d630a00094ef54c0871e210da0e0134f52401bc80cb6b2358c13d SHA512 17d4dbd64468a524311a24ca065537a5b21560388efd282f3fa873e6722f70db6f83e3e5615556450905c29d5df2cf0a0855f9c0b38bf23f0f8112501456d4ea
diff --git a/dev-ruby/text-hyphen/metadata.xml b/dev-ruby/text-hyphen/metadata.xml
new file mode 100644
index 000000000000..eb1e47f2edfb
--- /dev/null
+++ b/dev-ruby/text-hyphen/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-ruby/text-hyphen/text-hyphen-1.4.1-r2.ebuild b/dev-ruby/text-hyphen/text-hyphen-1.4.1-r2.ebuild
new file mode 100644
index 000000000000..78164eece2a6
--- /dev/null
+++ b/dev-ruby/text-hyphen/text-hyphen-1.4.1-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc History.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Hyphenates words according to the rules of the language the word is written in"
+HOMEPAGE="http://rubyforge.org/projects/text-format"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/hoe-2.8.0
+ dev-ruby/test-unit:2
+ )"
+
+all_ruby_prepare() {
+ sed -i -e '2igem "test-unit", ">= 2.0"' test/test_*.rb || die
+}