summaryrefslogtreecommitdiff
path: root/dev-ruby/test_declarative/test_declarative-0.0.5-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/test_declarative/test_declarative-0.0.5-r2.ebuild')
-rw-r--r--dev-ruby/test_declarative/test_declarative-0.0.5-r2.ebuild35
1 files changed, 0 insertions, 35 deletions
diff --git a/dev-ruby/test_declarative/test_declarative-0.0.5-r2.ebuild b/dev-ruby/test_declarative/test_declarative-0.0.5-r2.ebuild
deleted file mode 100644
index 338f473cbc6a..000000000000
--- a/dev-ruby/test_declarative/test_declarative-0.0.5-r2.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-# ruby22, ruby23: fails due to minitest incompatabilities.
-USE_RUBY="ruby21 ruby22 ruby23 ruby24"
-
-RUBY_FAKEGEM_TASK_TEST=""
-RUBY_FAKEGEM_TASK_DOC=""
-
-RUBY_FAKEGEM_EXTRADOC="README.textile"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Simply adds a declarative test method syntax to test/unit"
-HOMEPAGE="https://github.com/svenfuchs/test_declarative"
-SRC_URI="https://github.com/svenfuchs/test_declarative/tarball/v${PV} -> ${P}.tgz"
-RUBY_S="svenfuchs-test_declarative-*"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
-IUSE=""
-
-each_ruby_test() {
- case ${RUBY} in
- *ruby22|*ruby23|*ruby24)
- einfo "Tests do not work with ${RUBY}"
- ;;
- *)
- ${RUBY} test/test_declarative_test.rb || die "Tests failed."
- ;;
- esac
-}