summaryrefslogtreecommitdiff
path: root/dev-ruby/temple/temple-0.10.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/temple/temple-0.10.0.ebuild')
-rw-r--r--dev-ruby/temple/temple-0.10.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ruby/temple/temple-0.10.0.ebuild b/dev-ruby/temple/temple-0.10.0.ebuild
new file mode 100644
index 000000000000..888582c76846
--- /dev/null
+++ b/dev-ruby/temple/temple-0.10.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGES EXPRESSIONS.md README.md"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An abstraction and a framework for compiling templates to pure Ruby"
+HOMEPAGE="https://github.com/judofyr/temple"
+
+LICENSE="MIT"
+SLOT="0.7"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? (
+ dev-ruby/erubi
+ >=dev-ruby/tilt-2.0.1 )"