summaryrefslogtreecommitdiff
path: root/dev-ruby/simpleidn/simpleidn-0.2.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/simpleidn/simpleidn-0.2.1-r1.ebuild')
-rw-r--r--dev-ruby/simpleidn/simpleidn-0.2.1-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/simpleidn/simpleidn-0.2.1-r1.ebuild b/dev-ruby/simpleidn/simpleidn-0.2.1-r1.ebuild
new file mode 100644
index 000000000000..d0cc8bdfd09c
--- /dev/null
+++ b/dev-ruby/simpleidn/simpleidn-0.2.1-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+RUBY_FAKEGEM_EXTRAINSTALL="tables"
+
+RUBY_FAKEGEM_GEMSPEC="simpleidn.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Allows easy conversion from punycode ACE to unicode UTF-8 strings and vice-versa"
+HOMEPAGE="https://github.com/mmriis/simpleidn"
+SRC_URI="https://github.com/mmriis/simpleidn/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~arm ~x86"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/unf-0.1.4 =dev-ruby/unf-0.1*"
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/I s:^:#:' spec/spec_helper.rb || die
+ sed -i -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}