summaryrefslogtreecommitdiff
path: root/dev-ruby/simplecov-html/simplecov-html-0.13.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/simplecov-html/simplecov-html-0.13.1.ebuild')
-rw-r--r--dev-ruby/simplecov-html/simplecov-html-0.13.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ruby/simplecov-html/simplecov-html-0.13.1.ebuild b/dev-ruby/simplecov-html/simplecov-html-0.13.1.ebuild
new file mode 100644
index 000000000000..091a3128a648
--- /dev/null
+++ b/dev-ruby/simplecov-html/simplecov-html-0.13.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRAINSTALL="public views"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Generates a HTML report of your SimpleCov ruby code coverage results"
+HOMEPAGE="https://github.com/simplecov-ruby/simplecov-html"
+LICENSE="MIT"
+
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="doc"