summaryrefslogtreecommitdiff
path: root/dev-ruby/rubytest/rubytest-0.8.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rubytest/rubytest-0.8.1-r1.ebuild')
-rw-r--r--dev-ruby/rubytest/rubytest-0.8.1-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/rubytest/rubytest-0.8.1-r1.ebuild b/dev-ruby/rubytest/rubytest-0.8.1-r1.ebuild
new file mode 100644
index 000000000000..84956108303e
--- /dev/null
+++ b/dev-ruby/rubytest/rubytest-0.8.1-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby Test is a universal test harness for Ruby"
+HOMEPAGE="https://rubyworks.github.io/rubytest/"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/ae dev-ruby/qed )"
+ruby_add_rdepend "dev-ruby/ansi"
+
+all_ruby_prepare() {
+ # Help qed correctly find the root of the project
+ touch .ruby || die
+}
+
+each_ruby_test() {
+ ${RUBY} -S qed || die 'tests failed'
+}