summaryrefslogtreecommitdiff
path: root/dev-ruby/ruby-prof
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/ruby-prof')
-rw-r--r--dev-ruby/ruby-prof/Manifest2
-rw-r--r--dev-ruby/ruby-prof/ruby-prof-1.7.0.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-ruby/ruby-prof/Manifest b/dev-ruby/ruby-prof/Manifest
index e851ebbc49b5..664d885cd914 100644
--- a/dev-ruby/ruby-prof/Manifest
+++ b/dev-ruby/ruby-prof/Manifest
@@ -1,3 +1,5 @@
DIST ruby-prof-1.6.3.tgz 247407 BLAKE2B aac1ec36ee274faba919aa04be625b7b97ef61df105266f3d1b629cef6948db0bffbe67e70782f90a059221cb11cdb0df18031c9061f84cc882029cdde84629f SHA512 3172251fbd445c73f0eec734e09021ec0e375fd2f2999ec357569c679aa98ea5e0e08a18be1236e2572a8f0c302a1157d6a0d36ef04dffc4d0767accce629118
+DIST ruby-prof-1.7.0.tgz 251253 BLAKE2B e9cc60591d5cb8b3be528ba57c6374e7965b2f23394d468f3eb62a547e50edc7cc4ea99a6985726a30f063a0ce4823863b468e0ef2c89ef58cfbbe0362bfdb96 SHA512 ecea55a2a77d832f4aeca73aab578372a57a4fdf2cfc4db1fb14a899fed35ddfac79a078ab8207af8a4e70cdd0c4bb1e44a9ead8642e06b27ac4214d7d5981ef
EBUILD ruby-prof-1.6.3-r1.ebuild 1219 BLAKE2B 28b4e00c100c7299dd7254100111c2d6e363c2bc81def48f97e1388a7701667400967d700270fdf72d33bc2c224bfe1d989ad836f0750fe571f1ba233d564a89 SHA512 86261db638dccf5fd9cc9a14e8daed4b72c397d61044867c8a95ee310eff019eb141fc5812fbf278d479a105e647bdaadee91a922548081dbf4f24d01a9930b3
+EBUILD ruby-prof-1.7.0.ebuild 1219 BLAKE2B 820b12d02de757fe738a98f8160db359b938080f3169466965da20e63b04e7854a3bfdf12cc375988a14a7a8c274e9fac1873930b197bc23384a05d1d9290315 SHA512 b3fb2206f85b4bb253898a6a54ab6f75dac4ab7d28c5df8b42580e3f807b744bffb37637fe24d58cdfeb148c4dff50e308bd2d1aa606eaa4c16bb656f5e9273b
MISC metadata.xml 346 BLAKE2B 245dc508fb9933ff6a69b4e7c8a516ac9bb237798680ae70a8fbaeb57481520760f5a17a62cb045f82a955e0fc882fd84fb60d17b68bec1180b386355ca6b6fd SHA512 2cb1d6e31ac399f7faceccfd9dcc5e1a1e29bc10596ba3e0b3960ecc2bc215b21d351611e3ab6bfe7451fcee3bd4880a229b8266b7c8f6321bc79bdd5109b5d9
diff --git a/dev-ruby/ruby-prof/ruby-prof-1.7.0.ebuild b/dev-ruby/ruby-prof/ruby-prof-1.7.0.ebuild
new file mode 100644
index 000000000000..5de91d47156c
--- /dev/null
+++ b/dev-ruby/ruby-prof/ruby-prof-1.7.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGES"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_GEMSPEC="ruby-prof.gemspec"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/ruby_prof/extconf.rb)
+RUBY_FAKEGEM_EXTENSION_LIBDIR="lib"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A module for profiling Ruby code"
+HOMEPAGE="https://github.com/ruby-prof/ruby-prof"
+SRC_URI="https://github.com/ruby-prof/${PN}/archive/${PV}.tar.gz -> ${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2 dev-ruby/minitest )"
+
+all_ruby_prepare() {
+ # Avoid bundler
+ sed -i -e '/bundler/I s:^:#:' -e '/:build/ s:^:#:' Rakefile || die
+
+ sed -i -e '2igem "test-unit"' -e '/bundler/ s:^:#:' test/test_helper.rb || die
+
+ # We install the shared object in lib, not ext.
+ sed -i -e 's#../ext/ruby_prof#../lib/ruby_prof#' lib/ruby-prof.rb || die
+
+ # Avoid unneeded dependency on rake-compiler
+ sed -i -e '/extensiontask/ s:^:#:' \
+ -e '/ExtensionTask/,/end/ s:^:#:' Rakefile || die
+
+ # Don't strip library by default
+ sed -i -e '/LDFLAGS/ s/-s//' ext/ruby_prof/extconf.rb || die
+}