summaryrefslogtreecommitdiff
path: root/dev-ruby/ruby-glib2/ruby-glib2-3.1.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/ruby-glib2/ruby-glib2-3.1.3.ebuild')
-rw-r--r--dev-ruby/ruby-glib2/ruby-glib2-3.1.3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/ruby-glib2/ruby-glib2-3.1.3.ebuild b/dev-ruby/ruby-glib2/ruby-glib2-3.1.3.ebuild
new file mode 100644
index 000000000000..f28c14664b63
--- /dev/null
+++ b/dev-ruby/ruby-glib2/ruby-glib2-3.1.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+inherit ruby-ng-gnome2
+
+DESCRIPTION="Ruby Glib2 bindings"
+#KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+RDEPEND+=" >=dev-libs/glib-2"
+DEPEND+=" >=dev-libs/glib-2"
+
+ruby_add_bdepend "dev-ruby/pkg-config
+ test? ( >=dev-ruby/test-unit-2 )"
+
+all_ruby_prepare() {
+ # Skip spawn tests since our sandbox also provides items in the environment and this makes the test fragile.
+ rm -f test/test_spawn.rb || die
+
+ # Remove pregenerated Makefile since it will otherwise be shared by all targets.
+ rm -f Makefile Makefile.lib ext/glib2/Makefile || die
+}
+
+each_ruby_test() {
+ ${RUBY} test/run-test.rb || die
+}