summaryrefslogtreecommitdiff
path: root/dev-ruby/rspec/rspec-3.13.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rspec/rspec-3.13.0.ebuild')
-rw-r--r--dev-ruby/rspec/rspec-3.13.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ruby/rspec/rspec-3.13.0.ebuild b/dev-ruby/rspec/rspec-3.13.0.ebuild
new file mode 100644
index 000000000000..696efc9c4ae0
--- /dev/null
+++ b/dev-ruby/rspec/rspec-3.13.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="https://github.com/rspec/rspec"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+SUBVERSION="$(ver_cut 1-2)"
+
+ruby_add_rdepend "
+ =dev-ruby/rspec-core-${SUBVERSION}*
+ =dev-ruby/rspec-expectations-${SUBVERSION}*
+ =dev-ruby/rspec-mocks-${SUBVERSION}*"