summaryrefslogtreecommitdiff
path: root/dev-ruby/rspec-retry/rspec-retry-0.5.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rspec-retry/rspec-retry-0.5.7.ebuild')
-rw-r--r--dev-ruby/rspec-retry/rspec-retry-0.5.7.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ruby/rspec-retry/rspec-retry-0.5.7.ebuild b/dev-ruby/rspec-retry/rspec-retry-0.5.7.ebuild
new file mode 100644
index 000000000000..4b1e48fd3832
--- /dev/null
+++ b/dev-ruby/rspec-retry/rspec-retry-0.5.7.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Retry intermittently failing rspec examples"
+HOMEPAGE="https://github.com/NoRedInk/rspec-retry"
+IUSE=""
+SLOT="0"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+ruby_add_rdepend ">=dev-ruby/rspec-core-3.3:3"
+
+all_ruby_prepare() {
+ sed -i -e '/pry/ s:^:#:' spec/spec_helper.rb || die
+}