summaryrefslogtreecommitdiff
path: root/dev-ruby/rspec-json_expectations/rspec-json_expectations-2.2.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rspec-json_expectations/rspec-json_expectations-2.2.0-r1.ebuild')
-rw-r--r--dev-ruby/rspec-json_expectations/rspec-json_expectations-2.2.0-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ruby/rspec-json_expectations/rspec-json_expectations-2.2.0-r1.ebuild b/dev-ruby/rspec-json_expectations/rspec-json_expectations-2.2.0-r1.ebuild
new file mode 100644
index 000000000000..fd64c1dfd5aa
--- /dev/null
+++ b/dev-ruby/rspec-json_expectations/rspec-json_expectations-2.2.0-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Set of matchers and helpers to allow you test your APIs responses"
+HOMEPAGE="https://github.com/waterlink/rspec-json_expectations"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/rspec dev-util/cucumber )"
+
+each_ruby_test() {
+ ${RUBY} -S cucumber --format progress features || die
+}