summaryrefslogtreecommitdiff
path: root/dev-ruby/rspec-core/rspec-core-3.7.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rspec-core/rspec-core-3.7.1.ebuild')
-rw-r--r--dev-ruby/rspec-core/rspec-core-3.7.1.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/dev-ruby/rspec-core/rspec-core-3.7.1.ebuild b/dev-ruby/rspec-core/rspec-core-3.7.1.ebuild
index 2d053a7ba98a..78b1560ac9ae 100644
--- a/dev-ruby/rspec-core/rspec-core-3.7.1.ebuild
+++ b/dev-ruby/rspec-core/rspec-core-3.7.1.ebuild
@@ -71,6 +71,10 @@ all_ruby_prepare() {
sed -i -e '/be_highlighted/,/end/ s/32/33/' \
-e '/highlights core RSpec keyword-like methods/,/^ end/ s:^:#:' \
spec/rspec/core/formatters/syntax_highlighter_spec.rb || die
+
+ # Avoid a spec that depens on dev-ruby/rspec to lessen circular
+ # dependencies, bug 662328
+ sed -i -e '/loads mocks and expectations when the constants are referenced/askip "gentoo: bug 662328"' spec/rspec/core_spec.rb || die
}
each_ruby_prepare() {