summaryrefslogtreecommitdiff
path: root/dev-ruby/rr/rr-3.1.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rr/rr-3.1.1.ebuild')
-rw-r--r--dev-ruby/rr/rr-3.1.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/rr/rr-3.1.1.ebuild b/dev-ruby/rr/rr-3.1.1.ebuild
new file mode 100644
index 000000000000..a59e05489de1
--- /dev/null
+++ b/dev-ruby/rr/rr-3.1.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC=rr.gemspec
+
+inherit ruby-fakegem
+
+DESCRIPTION="A double framework featuring a selection of double techniques and a terse syntax"
+HOMEPAGE="https://rr.github.io/rr/"
+SRC_URI="https://github.com/rr/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="test"
+
+ruby_add_bdepend "test? (
+ dev-ruby/minitest
+ dev-ruby/diff-lcs
+ dev-ruby/test-unit-rr )"
+
+each_ruby_test() {
+ ${RUBY} test/run-test.rb || die
+}