summaryrefslogtreecommitdiff
path: root/dev-ruby/rouge/rouge-2.2.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rouge/rouge-2.2.1.ebuild')
-rw-r--r--dev-ruby/rouge/rouge-2.2.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/rouge/rouge-2.2.1.ebuild b/dev-ruby/rouge/rouge-2.2.1.ebuild
new file mode 100644
index 000000000000..70e9a003fa9a
--- /dev/null
+++ b/dev-ruby/rouge/rouge-2.2.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Yet-another-markdown-parser using a strict syntax definition in pure Ruby"
+HOMEPAGE="https://github.com/jneen/rouge"
+#SRC_URI="https://github.com/jneen/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "doc? ( dev-ruby/redcarpet )"
+ruby_add_rdepend "dev-ruby/redcarpet
+ !!dev-ruby/rouge:0"
+
+RESTRICT="test"
+# Depends on dev-ruby/wrong, which is not packaged yet.