summaryrefslogtreecommitdiff
path: root/dev-ruby/rouge/rouge-1.11.1-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rouge/rouge-1.11.1-r2.ebuild')
-rw-r--r--dev-ruby/rouge/rouge-1.11.1-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/rouge/rouge-1.11.1-r2.ebuild b/dev-ruby/rouge/rouge-1.11.1-r2.ebuild
new file mode 100644
index 000000000000..cd22a64c59ad
--- /dev/null
+++ b/dev-ruby/rouge/rouge-1.11.1-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby23 ruby24"
+
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
+RUBY_FAKEGEM_TASK_TEST="spec"
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Yet-another-markdown-parser using a strict syntax definition in pure Ruby"
+HOMEPAGE="https://github.com/jneen/rouge"
+SRC_URI="https://github.com/jneen/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "doc? ( dev-ruby/redcarpet )"
+ruby_add_rdepend "dev-ruby/redcarpet"
+
+RESTRICT="test"
+# Depends on dev-ruby/wrong, which is not packaged yet.